»
« home   paste   Anonymous | Login | Signup for a new account 09-22-2017 15:30 CEST
 
* X »
«
GeSHi - Generic Syntax Highlighter Syntax Coloriser for PHP
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000036 [GeSHi] lang trivial always 12-10-05 05:50 02-18-06 11:48
Reporter BenBE View Status public  
Assigned To BenBE
Priority low Resolution fixed  
Status closed   Product Version 1.1.1alpha2
Summary 0000036: Detection of some asm instr in non-instr-context
Description For the delphi/delphi/asm subcontext I found in the Delphi Online Help that there are some reserved words (namely AND, NOT, OR, XOR, SHL and SHR) that can be used in expressions after a mnemonic to perform some calculations

e.g.

ADD EAX, ($0815 AND $4711) SHL 4

The problem with them is that they are also part of the instr/i386 subset and can't find a way ATM using the DCP which would allow to distinguish the use of them from normal instructions

Basically it's not that difficult because the Inline Assembler of Delphi is line-oriented ;-) But the current parser doesn't get informed of them ;-)
Additional Information Please pass through \n to the DCP
Attached Files

- Relationships
child of 0000006assigned BenBE Delphi support 

- Notes
(0000116)
nigel
12-10-05 12:38

\n is passed through, inside whitespace ATM AFAIK.
 
(0000117)
BenBE
12-11-05 00:23

Using the following output of

Here is
a linefeed

I get

GeSHiDelphiCodeParser::parseToken("Here"...,delphi/delphi)
GeSHiDelphiCodeParser::parseToken(" "...,delphi/delphi)
GeSHiDelphiCodeParser::parseToken("is"...,delphi/delphi/keywords)
GeSHiDelphiCodeParser::parseToken(""...,delphi/delphi)
GeSHiDelphiCodeParser::parseToken("a"...,delphi/delphi)
GeSHiDelphiCodeParser::parseToken(" "...,delphi/delphi)
GeSHiDelphiCodeParser::parseToken("linefeed"...,delphi/delphi)

which would indicate that the \n got truncated away. Please review this.
 
(0000118)
nigel
12-11-05 13:07

Found the problem. You were detecting newlines incorrectly!

'\n' is NOT a newline: it is the character \ followed by the character n
"\n" IS a new line.

I changed the debug line to show this, since firefox won't break the output source when you view source at this position.
 
(0000333)
nigel
02-18-06 11:48

Issue closed.
 

- Issue History
Date Modified Username Field Change
12-10-05 05:50 BenBE New Issue
12-10-05 05:50 BenBE Status new => assigned
12-10-05 05:50 BenBE Assigned To  => BenBE
12-10-05 05:51 BenBE Relationship added child of 0000006
12-10-05 12:38 nigel Note Added: 0000116
12-11-05 00:23 BenBE Note Added: 0000117
12-11-05 13:07 nigel Note Added: 0000118
12-11-05 13:07 nigel Status assigned => resolved
12-11-05 13:07 nigel Resolution open => fixed
12-11-05 13:07 nigel Fixed in Version  => 1.1.1alpha2
02-18-06 11:48 nigel Status resolved => closed
02-18-06 11:48 nigel Note Added: 0000333

  


Mantis 1.0.0rc2[^]
Copyright © 2000 - 2005 Mantis Group
43 total queries executed.
34 unique queries executed.
Powered by Mantis Bugtracker