»
« home   paste   Anonymous | Login | Signup for a new account 11-17-2017 18:14 CET
 
* X »
«
GeSHi - Generic Syntax Highlighter Syntax Coloriser for PHP
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000004 [GeSHi] core minor always 10-20-05 20:37 12-11-05 22:26
Reporter nigel View Status public  
Assigned To nigel
Priority low Resolution fixed  
Status closed   Product Version 1.1.0alpha3
Summary 0000004: ^ for regular expressions doesn't match in string_javascript
Description For some reason, ^ can't be used to mark the beginning of a context for string_javascript in HTML strings - e.g. REGEX#^return# doesn't match.
Additional Information
Attached Files

- Relationships

- Notes
(0000001)
nigel
10-20-05 20:39

Reason found. When using a ^ before both the return and javascript: starters, both starters would be checked to see if they occur in the source. With ^, neither of them are, as the keywords would have to be at the very start of the source.

This is being deferred to 1.1.1, where a permanent solution will be put in place, possibly by adding another field to the GeSHiContext class to signal that this context should never be removed no matter how useless it is.
 
(0000028)
nigel
10-26-05 01:29

Fix in CVS. string_javascript for HTML uses this, since the regular expressions it uses to match its starter are not suitable for testing for whether it's worthy of retaining.
 
(0000122)
nigel
12-11-05 22:26

Issue closed.
 

- Issue History
Date Modified Username Field Change
10-20-05 20:37 nigel New Issue
10-20-05 20:37 nigel Status new => assigned
10-20-05 20:37 nigel Assigned To  => nigel
10-20-05 20:39 nigel Note Added: 0000001
10-20-05 20:39 nigel Projection none => minor fix
10-26-05 01:29 nigel Note Added: 0000028
10-26-05 01:29 nigel Resolution open => fixed
12-05-05 09:42 nigel Status assigned => resolved
12-05-05 09:42 nigel Fixed in Version  => 1.1.1alpha3
12-11-05 22:26 nigel Status resolved => closed
12-11-05 22:26 nigel Note Added: 0000122

  


Mantis 1.0.0rc2[^]
Copyright © 2000 - 2005 Mantis Group
33 total queries executed.
27 unique queries executed.
Powered by Mantis Bugtracker