»
« home   paste   Anonymous | Login | Signup for a new account 09-22-2017 15:32 CEST
 
* X »
«
GeSHi - Generic Syntax Highlighter Syntax Coloriser for PHP
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000007 [GeSHi] core feature always 10-20-05 20:49 02-18-06 11:55
Reporter nigel View Status public  
Assigned To nigel
Priority high Resolution fixed  
Status closed   Product Version 1.1.0alpha6
Summary 0000007: Theming support
Description It should be possible to theme the output.

Style data will be removed from context files and instead defined in a theme file.

When this is done, care needs to be taken to ensure that a theme can miss some information and stuff will be highlighted reasonably, i.e. have some general rules that match "*keyword*".

OCCs may need to be renamed to have their parent at their front.
Additional Information
Attached Files

- Relationships

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

SYSTEM WARNING: Creating default object from empty value

related to 0000044assigned nigel Create additional themes 
parent of 0000043closed nigel additional functions for theme enumeration 
parent of 0000048closed nigel Shorten paths for themes 
parent of 0000054closed nigel $G->setTheme has no effect 

- Notes
(0000157)
nigel
12-20-05 23:50

Preliminary support implemented.

OCCs have NOT yet been renamed, this should be looked into/done.

Nor has good support been added for matching general things (basic support is in place: if context not known then return default black colour).

Theming needs to be done for qbasic, web3d and codeworker as well.
 
(0000166)
nigel
12-22-05 09:55

Have done the OCC renaming (as part of solving bug 48). I have decided NOT to rename them because implementation is too hard. Instead, you can use the loadStyles() method to load defaults for that language, then setRawStyle method to override specific things you want.

Now all that remains is general rules.
 
(0000283)
nigel
01-29-06 17:51

I don't know whether there is much left to do with theming support. The idea of "general" rules is really covered by the "default" theme.

Of the bugs above that are related to this bug, the only unfixed bug is about creating additional themes, which is really only "related" to this bug rather than being a child. And 0000043 is in feedback, but I think that's nearly done.

So is there anything else to do for theming?

If not, I will release 1.1.1a4, then get onto fixing bug 0000002.
 
(0000288)
BenBE
01-30-06 02:39

I think there's nothing else left for theming support that is in the scope of this bug. 1.1.a4 can be released.
 
(0000342)
nigel
02-18-06 11:55

Issue closed.
 

- Issue History
Date Modified Username Field Change
10-20-05 20:49 nigel New Issue
10-20-05 20:49 nigel Status new => assigned
10-20-05 20:49 nigel Assigned To  => nigel
10-20-05 20:50 nigel Projection none => major rework
12-20-05 23:50 nigel Note Added: 0000157
12-21-05 23:36 BenBE Relationship added parent of 0000043
12-21-05 23:38 BenBE Relationship added parent of 0000048
12-21-05 23:40 BenBE Relationship added parent of 0000044
12-22-05 09:55 nigel Note Added: 0000166
12-24-05 10:22 BenBE Relationship added parent of 0000054
01-29-06 17:51 nigel Note Added: 0000283
01-29-06 18:11 nigel Status assigned => feedback
01-30-06 02:37 BenBE Relationship replaced related to 0000044
01-30-06 02:39 BenBE Status feedback => resolved
01-30-06 02:39 BenBE Fixed in Version  => 1.1.1alpha4
01-30-06 02:39 BenBE Resolution open => fixed
01-30-06 02:39 BenBE Note Added: 0000288
02-18-06 11:55 nigel Status resolved => closed
02-18-06 11:55 nigel Note Added: 0000342

  


Mantis 1.0.0rc2[^]
Copyright © 2000 - 2005 Mantis Group
53 total queries executed.
39 unique queries executed.
Powered by Mantis Bugtracker