»
« home   paste   Anonymous | Login | Signup for a new account 05-28-2017 14:12 CEST
 
* X »
«
GeSHi - Generic Syntax Highlighter Syntax Coloriser for PHP
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000071 [GeSHi] core minor sometimes 05-07-06 22:20 05-27-06 23:42
Reporter BenBE View Status public  
Assigned To nigel
Priority normal Resolution fixed  
Status closed   Product Version 1.1.1alpha4
Summary 0000071: Current OOP behaviour not suitable for Delphi
Description The current way OOP symbols are handle is not suitable for Delphi as it allows for situations which are not valid Delphi source.
Additional Information For Delphi the only OOP followup is [_A-Za-z] which is the start of the next identifier.
Attached Files

- Relationships
child of 0000006assigned BenBE Delphi support 

- Notes
(0000356)
nigel
05-14-06 13:42

I've removed "(" (and "*") from the characters that are highlighted as OO tokens. In your example the brace will probably end up as a symbol, but that's not really related to this bug, since now that source won't be detected as an OO token.

In fact, if you look closely at it, you might see that if you removed the "." from the symbols array elsewhere, then the "." in this example won't be highlighted, which probably proves that this is fixed.
 
(0000371)
nigel
05-16-06 20:45

Reminder sent to: BenBE

Is this fixed for you?
 
(0000377)
BenBE
05-16-06 23:07

Currently some trouble with latest sources. Couldn't yet test completely, but as far as I noticed it seemed to work.
 
(0000382)
nigel
05-17-06 09:41

Well just leave a note when you've had a chance to test it.
 
(0000398)
BenBE
05-18-06 09:54

The issue is fixed with IMHO. The used regexp doesn't conflict (much) with the Delphi syntax. The only point where it does is acceptable (Delphi would not allow for spaces after the splitter, but this can be ignored as it's semantically correct.
 
(0000411)
nigel
05-27-06 23:42

Issue closed.
 

- Issue History
Date Modified Username Field Change
05-07-06 22:20 BenBE New Issue
05-07-06 22:20 BenBE Status new => assigned
05-07-06 22:20 BenBE Assigned To  => nigel
05-14-06 13:43 nigel Note Added: 0000356
05-14-06 13:43 nigel Status assigned => feedback
05-15-06 01:43 BenBE Relationship added child of 0000006
05-16-06 20:45 nigel Note Added: 0000371
05-16-06 23:07 BenBE Note Added: 0000377
05-17-06 09:41 nigel Note Added: 0000382
05-18-06 09:54 BenBE Note Added: 0000398
05-18-06 09:54 BenBE Status feedback => resolved
05-18-06 09:54 BenBE Resolution open => fixed
05-18-06 09:54 BenBE Fixed in Version  => 1.1.1alpha5
05-27-06 23:42 nigel Status resolved => closed
05-27-06 23:42 nigel Note Added: 0000411

  


Mantis 1.0.0rc2[^]
Copyright © 2000 - 2005 Mantis Group
47 total queries executed.
36 unique queries executed.
Powered by Mantis Bugtracker