»
« home   paste   Anonymous | Login | Signup for a new account 07-28-2017 16:50 CEST
 
* X »
«
GeSHi - Generic Syntax Highlighter Syntax Coloriser for PHP
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000076 [GeSHi] lang trivial always 05-15-06 01:28 05-27-06 23:45
Reporter BenBE View Status public  
Assigned To nigel
Priority low Resolution fixed  
Status closed   Product Version 1.1.1alpha4
Summary 0000076: Integers after subranges not highlighted
Description When specifying a subrange like 0..7 the 7 is not highlighted as integer.
Additional Information I expect the problem to be some restriction in the integer detection regexp of the new lang format ... 1.1.1a4 had had solved this problem already...
Attached Files

- Relationships
child of 0000006assigned BenBE Delphi support 

- Notes
(0000366)
BenBE
05-16-06 08:20

Reminder sent to: nigel

Wasn't this issue fixed once? Could you have a look into your changes re-causing this but?
 
(0000368)
nigel
05-16-06 10:07

I added the . to prevent integers hijacking double numbers, e.g. 1.0 was being highlighted with the 1 as an int and the .0 as a double. I'll have another look at this.
 
(0000374)
nigel
05-16-06 22:47

Having a look at this again, it looks like you might have to add special codeparser handling for this case.

It's perfectly valid to try and prevent ints from highligting [num]. because that might be the beginning of a double number.

It's also perfectly valid to prevent ints from highlighting .[num] because again that might be in a double number.

This problem happens because in reality the double regex should be applied before the integer regex, else the regexes will get way too long. I will see if I can try and force a way for the double regex to be put in before the int one, for the meantime you can just swap the order of useStandardDoubles/Ints calls to (hopefully) fix this.
 
(0000379)
BenBE
05-16-06 23:11

The only case in Delphi where ints may be preceeded by . is the subset spec case where there MUST be exactly 2 . following without anything in between.

The old langfile could do this without CP too *g*
 
(0000383)
nigel
05-17-06 09:41

I think I've thought of a solution that involves delaying of the setting of the double/int regexes until after the context is loaded. I will work on it tonight.
 
(0000389)
nigel
05-17-06 21:36

Fix in CVS. A bit more complicated than I thought but it works fine (and provides a bit of flexibility for contexts to clean up after the init function is called).
 

- Issue History
Date Modified Username Field Change
05-15-06 01:28 BenBE New Issue
05-15-06 01:28 BenBE Status new => assigned
05-15-06 01:28 BenBE Assigned To  => BenBE
05-15-06 01:48 BenBE Relationship added child of 0000006
05-16-06 08:20 BenBE Issue Monitored: nigel
05-16-06 08:20 BenBE Note Added: 0000366
05-16-06 10:07 nigel Note Added: 0000368
05-16-06 11:30 nigel Assigned To BenBE => nigel
05-16-06 22:47 nigel Note Added: 0000374
05-16-06 23:11 BenBE Note Added: 0000379
05-17-06 09:41 nigel Note Added: 0000383
05-17-06 21:36 nigel Status assigned => resolved
05-17-06 21:36 nigel Fixed in Version  => 1.1.1alpha5
05-17-06 21:36 nigel Resolution open => fixed
05-17-06 21:36 nigel Note Added: 0000389
05-27-06 23:45 nigel Status resolved => closed

  


Mantis 1.0.0rc2[^]
Copyright © 2000 - 2005 Mantis Group
48 total queries executed.
36 unique queries executed.
Powered by Mantis Bugtracker