»
« home   paste   Anonymous | Login | Signup for a new account 09-22-2017 15:29 CEST
 
* X »
«
GeSHi - Generic Syntax Highlighter Syntax Coloriser for PHP
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000077 [GeSHi] lang minor random 05-15-06 01:38 05-27-06 23:45
Reporter BenBE View Status public  
Assigned To BenBE
Priority low Resolution fixed  
Status closed   Product Version 1.1.1alpha4
Summary 0000077: Aliasing problems on non-aliased context
Description While looking at the operators And, OR, NOT and some others I noticed they being highlighted as delphi/delphi/asm/keyop although they are outside the any ASM context.

Example:
http://viewcvs.omorphia.org/uallCollection/uallDisasmEx.pas?rev=1.7 [^]
Find any instance of "and", "or" "not", "xor", ...

ASM is not aliased (AFAIR) but seems to be prefered here over the definitions of reserved words of delphi/delphi
Additional Information
Attached Files

- Relationships
child of 0000006assigned BenBE Delphi support 

- Notes
(0000390)
nigel
05-17-06 21:49

I had a look at this: it's your problem :D

If you comment out the addChildLanguage call then you will see that nothing changes. So it's not the fault of the language files. The ASM file isn't even included if you comment that out, and ASM isn't mentioned elsewhere in the delphi language file, so it's not that.

In fact, it's the code parser. You've got some kind of open/close block thing going on, and some overriding of context names for and/or etc. if you've detected that you're in an ASM block. Perhaps your detection is faulty?
 
(0000393)
BenBE
05-18-06 05:51

I'll have to look at the CP stuff once again as I primarily concentrated on the language file for now. I'll have to see, but I guess that will be the cause of that trouble ;-)
 
(0000394)
BenBE
05-18-06 09:37

I added an additional check inside the code parser and now this works just fine again.
 

- Issue History
Date Modified Username Field Change
05-15-06 01:38 BenBE New Issue
05-15-06 01:38 BenBE Status new => assigned
05-15-06 01:38 BenBE Assigned To  => nigel
05-15-06 01:44 BenBE Relationship added child of 0000006
05-17-06 21:47 nigel Assigned To nigel => BenBE
05-17-06 21:49 nigel Note Added: 0000390
05-18-06 05:51 BenBE Note Added: 0000393
05-18-06 09:37 BenBE Note Added: 0000394
05-18-06 09:37 BenBE Status assigned => resolved
05-18-06 09:37 BenBE Resolution open => fixed
05-18-06 09:37 BenBE ETA none => < 1 day
05-18-06 09:37 BenBE Fixed in Version  => 1.1.1alpha5
05-27-06 23:45 nigel Status resolved => closed

  


Mantis 1.0.0rc2[^]
Copyright © 2000 - 2005 Mantis Group
41 total queries executed.
33 unique queries executed.
Powered by Mantis Bugtracker