»
« home   paste   Anonymous | Login | Signup for a new account 07-28-2017 16:48 CEST
 
* X »
«
GeSHi - Generic Syntax Highlighter Syntax Coloriser for PHP
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000078 [GeSHi] lang minor sometimes 05-16-06 08:18 05-27-06 23:45
Reporter BenBE View Status public  
Assigned To BenBE
Priority low Resolution fixed  
Status closed   Product Version 1.1.1alpha4
Summary 0000078: Delphi Code Parser dropping some contexts
Description When highlighting

CALL Format

as delphi/asm you will get CALL highlighted with the succeeding Format missing.
Additional Information The problem exists because of a cache system inside the Code Parser to detect some special constructs that need alteration. If such a construct is used at the end it won't get passed to the output.

To solve this issue a "clean up" notification to the CP would be required.
Attached Files

- Relationships

- Notes
(0000370)
nigel
05-16-06 11:33

There is already a flush() method that you should implement to return any remaining tokens. Just implement that and your problem should be solved. Java already uses this.
 
(0000376)
BenBE
05-16-06 23:05

k, 'll do ASAP.
 
(0000395)
BenBE
05-18-06 09:40

Just combined fixing this with other problems ;-)
 

- Issue History
Date Modified Username Field Change
05-16-06 08:18 BenBE New Issue
05-16-06 08:18 BenBE Status new => assigned
05-16-06 08:18 BenBE Assigned To  => BenBE
05-16-06 11:33 nigel Note Added: 0000370
05-16-06 23:05 BenBE Note Added: 0000376
05-18-06 09:40 BenBE Note Added: 0000395
05-18-06 09:40 BenBE Status assigned => resolved
05-18-06 09:40 BenBE Resolution open => fixed
05-18-06 09:40 BenBE ETA none => < 1 day
05-18-06 09:40 BenBE Fixed in Version  => 1.1.1alpha5
05-27-06 23:45 nigel Status resolved => closed

  


Mantis 1.0.0rc2[^]
Copyright © 2000 - 2005 Mantis Group
34 total queries executed.
28 unique queries executed.
Powered by Mantis Bugtracker