»
« home   paste   Anonymous | Login | Signup for a new account 05-28-2017 14:15 CEST
 
* X »
«
GeSHi - Generic Syntax Highlighter Syntax Coloriser for PHP
  

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000098 [GeSHi] lang crash always 01-26-07 01:50 01-31-07 09:42
Reporter BenBE View Status public  
Assigned To Knut
Priority low Resolution fixed  
Status closed   Product Version 1.1.2alpha3
Summary 0000098: GeSHi crashes on parsing csharp/common
Description When trying to highligh sources with C# language (csharp) using sources as of rev 882 (877) I get the following error while executing:

Warning:
Missing argument 2 for GeSHiConext:addChildLanguage(), called in /geshi/language/csharp/common.php on line 194 and defined in ...
Additional Information The function causing the problem is:

function geshi_csharp_doc_comment (&$context)
{
    $context->addDelimiters('///', "\n");
    // $context->setComplexFlag(GESHI_COMPLEX_TOKENISE);
    // $this->_contextStyleType = GESHI_STYLE_COMMENTS;
    // Add XML
    $context->addChildLanguage('xml/xml'); //<-- THIS LINE!!!
}
Attached Files

- Relationships

- Notes
(0000475)
Knut
01-31-07 09:42

Yes, it was a little error I planned to implement. It got into the commit by accident, and it was planned that there'd be a separate language, xml/csdoc.

The issue is now (as of rev. 892 latest) solved.

Regards, Knut
 

- Issue History
Date Modified Username Field Change
01-26-07 01:50 BenBE New Issue
01-31-07 09:42 Knut Status new => resolved
01-31-07 09:42 Knut Fixed in Version  => 1.1.2alpha2
01-31-07 09:42 Knut Resolution open => fixed
01-31-07 09:42 Knut Assigned To  => Knut
01-31-07 09:42 Knut Note Added: 0000475
01-31-07 09:42 Knut Status resolved => closed

  


Mantis 1.0.0rc2[^]
Copyright © 2000 - 2005 Mantis Group
30 total queries executed.
26 unique queries executed.
Powered by Mantis Bugtracker